TIP: Use Markdown or, <pre> for multi line code blocks / <code> for inline code.
These forums are read-only and for archival purposes only!
Please join our new forums at discourse.kohanaframework.org
The requested URL / was not found on this server. / no input file specified
  • Hello, i can't get Kohana to work. On my local webserver (MAMP) everything worked good, but now I can't get something to work. If i call the folder i get an

    Kohana_HTTP_Exception [ 404 ]: The requested URL / was not found on this server.

    And when I call a controller i get "no input file specified."

    My htaccess lookes like this:

    # Turn on URL rewriting
    RewriteEngine On
    
    # Installation directory
    RewriteBase /hcderboss/
    
    # Protect hidden files from being viewed
    <Files .*>
        Order Deny,Allow
        Deny From All
    </Files>
    
    # Protect application and system files from being viewed
    RewriteRule ^(?:application|modules|system)\b.* index.php/$0 [L]
    
    # Allow any files or directories that exist to be displayed directly
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    
    # Rewrite all other URLs to index.php/URL
    RewriteRule .* index.php/$0 [PT]
    

    and my init like this:

    Kohana::init(array(
        'base_url'   => '/hcderboss/',
        'index_file' => false
    ));
    

    I googled for these errors and found some topics here but it didn't help :(

  • Is mod_rewrite enabled?

  • tested with

    RewriteRule .* index.php?/$0 [PT]

  • SCRIPT_FILENAME is not specified probably because PHP is configured in CGI/FastCGI, try:

    # RewriteRule .* index.php/$0 [PT] RewriteRule .* index.php/$1 [PT]

  • Found a way to change cgi to modPHP but something still won't work.

    Homepage says "The requested URL / was not found on this server." and when I call a controller it says "The requested URL radio was not found on this server". instead of input file not specified.

  • Okay, it seems to work no but theres a strange behavior. Everytime I call URL::site() it generates links like this: /folder_of_installation/1/controller/model

  • RewriteRule .* index.php?/$0 [PT]

    on every project ...

  • That didn't solve my problem :/ Same mistake

  • So, i uploaded that kohana installation to a server where a previously kohana project (older kohana version) works good. But this installations freaks me out.

    I still get the /1/ on every url.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion