TIP: Use Markdown or, <pre> for multi line code blocks / <code> for inline code.
These forums are read-only and for archival purposes only!
Please join our new forums at discourse.kohanaframework.org
[SOLVED] "PCRE has not been compiled with Unicode property support."
  • Hi guys,
    I'm trying to get a pass on the install.php test for the PCRE. I'm using kohana 3.0 rc3 base.

    I installed the latest version of PCRE, installed with the following flags:
    ./configure --enable-utf8 --enable-unicode-properties
    Then reboot the machine, re-install the latest version of php and reboot again.

    However, I still can't pass the PCRE test, I get the error:
    PCRE has not been compiled with Unicode property support.

    If I do:
    pcretest -C

    I get the following output:
    PCRE version 7.9 2009-04-11
    Compiled with
    UTF-8 support
    Unicode properties support
    Newline sequence is LF
    \R matches all Unicode newlines
    Internal link size = 2
    POSIX malloc threshold = 10
    Default match limit = 10000000
    Default recursion depth limit = 10000000
    Match recursion uses stack

    Clearly PCRE is installed correctly. Is there some other step I need to do with PHP?
  • Turns out you need to recompile php after installing a new version of PCRE... However due to a php bug you need to remove this line when you config:
    and add this line:

    Then run:
    $ make clean
    $ make
    $ make install
    $ /etc/init.d/httpd restart

    If you don't php will continue to load the old library.
  • I'm experiencing the "PCRE has not been compiled with Unicode property support." warning, and I'm not an advanced command-line guy. I've installed PCRE, but seem to be getting hung up and the obvious stuff. Maybe you could point me in the right direction.

    I can't seem to figure out where to run the './configure' command, or where to run the 'make' commands to recompile php. Does this vary from server to server? If I could just figure out how to re-compile my php with the pcre stuff I think I'd be set.

    You also mentioned "...you need to remove this line when you config..." I don't really know what you mean by 'when you config'.

    I think my issues are probably obvious to someone who know their way around UNIX better, but I can't even search in Google for the right things it seems, so any help at all is appreciated. Thanks!
  • Hi,
    I'm a linux noob but it's relatively easy to do this. You will need to download php to your server and recompile it.

    I recommend googling how to install php on linux for good documentation. Here are some good links with information and walk throughs:

    However, this is what you need to do:

    - create a page on your server with at the top
    - open the page in a web browser
    - copy the ./configure section at the top
    - remove all the single quotes from that text block
    - remove anything like "--with-pcre-regex=/usr"
    - add "--enable-utf8" (without the quotes)

    - ssh into your server as root
    - download a new version of php, ex: wget [php url here]
    - untar the file
    - change to that directory
    - then run the ./configure block from above
    - run make clean
    - run make
    - run make install
    - copy over php.ini from the source directory to your server's php install directory and edit is as necessary
    - reload apache (or you may need to reboot the server)

    You may run into issues like I did such as "apxs was not found" - basically you may need to install some additional dependencies.
    So I had to run commands like: yum install httpd-devel
    ... several times for various dependencies and then run ./configure again...

    For the exact syntax if you run into any issues trying to compile php check out these links:
  • Can someone help me with this error when trying to run ./configure

    configure: error: no acceptable cc found in $PATH

  • ^ Do you have gcc and related tools installed?

    Which distribution do you use?

  • I've installed Xcode tools (from my OSX dvd). I'm running OSX 10.6 (Sorry but I'm a noob at things like these...)

  • Sorry, no special OSX expirience :(

    You have to install source compiler and builder tool. Don't know what is OSX using...

    Hope you'll solve the problem.

  • @jonnyjon: You rock. I spent hours on this problem before finding this thread. It was so aggravating doing compile after compile after compile.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion