TIP: Use Markdown or, <pre> for multi line code blocks / <code> for inline code.
These forums are read-only and for archival purposes only!
Please join our new forums at discourse.kohanaframework.org
14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
  • 14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    i add
    curl_setopt ($ch, CURLOPT_SSL_VERIFYPEER, 0);
    curl_setopt ($ch, CURLOPT_SSL_VERIFYHOST, 0);
    Hope to have a better way~
  • The server you are attempting to get data from does not have a valid certificate.
  • I know, but I do not know how to install it
  • This forum is for Kohana help, not SSL certificate help.
  • How do i accept a Self Signed Certificate ?

    I have the same issue using a Self Signed Certificate on a development environment:

    Request_Exception [ 0 ]: Error fetching remote http://localhost/test [ status 0 ] SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed ~ SYSPATH/classes/kohana/request/client/curl.php [ 100 ]

    If liushan solution is too much of a security risk, would it at least be possible to set CURLOPT_CAINFO using Request::factory ?

  • Request_Client_External have a public function options($key = NULL, $value = NULL), but i dont know howto access is using Request::factory.

    For now the only solutions seems to edit Kohana_Request_Client_Curl, wich i preffer not:

    $this->_options[CURLOPT_SSL_VERIFYHOST] = 0;
    $this->_options[CURLOPT_SSL_VERIFYPEER] = 0;
  • @davidvandertuijn Request::factory(...)->get_client()->options(...)

  • @shadowhand I found that solution elsewhere on the forums unfortunately, the function get_client doesn't exist.

    ErrorException [ Fatal Error ]: Call to undefined method Request::get_client()

  • Fixed!

    It should be:


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion