TIP: Use Markdown or, <pre> for multi line code blocks / <code> for inline code.
These forums are read-only and for archival purposes only!
Please join our new forums at discourse.kohanaframework.org
[SOLVED] kohana v3 kohana-email problem?
  • Edit:

    Solved - My mistake... I had old version of Papercut (http://papercut.codeplex.com/) ant that's why the problem came ...

    ============================================

    Hi - I have a little problem...
    I downloaded this module:
    http://github.com/banks/kohana-email

    But when I try to send something (in main controller for test) I'm getting wierd things

    I make it like this:

    controller:

    $mail = View::factory('email/notifications/pl/registered')->render();
    Email::send([email protected]', [email protected]', 'nowe konto', $mail, TRUE);


    view:

    <?php defined('SYSPATH') OR die('No direct access allowed.'); ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"&gt;
    <html xmlns="http://www.w3.org/1999/xhtml"&gt;
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    </head>
    <body style="font: 14px Tahoma, sans-serif;">
    test
    </body>
    </html>


    The problem is that I get unexpected "=" signs inside output email:


    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://w=ww.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"&gt;
    <html xmlns="http=://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Typ=e" content="text/html; charset=utf-8" />

    </head>
    <body= style="font: 14px Tahoma, sans-serif;">
    test
    </body>
    <=/html>


    What is wrong with this helper?