TIP: Use Markdown or, <pre> for multi line code blocks / <code> for inline code.
These forums are read-only and for archival purposes only!
Please join our new forums at discourse.kohanaframework.org
Kohanut CMS: Xampp Installation Problem
  • I am trying to setup kohanut CMS demo in my localhost. Actually I am using Xampp.
    Paths:
    E:\xampp\htdocs\subha\kohanacms
    http://localhost/subha/kohanacms/

    I have changed the base_url in the bootstrap.php file to 'base_url' => 'http://localhost/subha/kohanacms/',
    But when i try to install http://localhost/subha/kohanacms/admin/install/
    it was redirecting to http://localhost/

    Kindly help me to install the CMS in my local machine.
  • base_url should be relative to the document root, in this case htdocs.

    Try setting base_url to "subha/kohanacms"

    You will also have to edit the .htaccess file and change the rewrite base to subha/kohanacms
  • Yes thanks. it worked

    But when i move on to the install page http://localhost/subha/kohanacms/admin/install/

    it ask for the password. i have set up my DB details in application/config/database.php
    But it shows me an error after entering the password.

    the problem is with out creating the table it tries to fetch the data from the table this caused the error think so.

    [Database_Exception [ 1146 ]: Table 'kohanut3.kohanut_pages' doesn't exist [ SELECT `kohanut_pages`.`id`, `kohanut_pages`.`url`, `kohanut_pages`.`name`, `kohanut_pages`.`layout`, `kohanut_pages`.`islink`, `kohanut_pages`.`shownav`, `kohanut_pages`.`showmap`, `kohanut_pages`.`title`, `kohanut_pages`.`metadesc`, `kohanut_pages`.`metakw`, `kohanut_pages`.`lft`, `kohanut_pages`.`rgt`, `kohanut_pages`.`lvl`, `kohanut_pages`.`scp` FROM `kohanut_pages` WHERE `url` = 'subha/kohanacms' AND `islink` = 0 LIMIT 1 ] ]

    My i know how to proceed on this ?
  • It sounds like something is still wrong with your base_url. Do you mind pastebinning your bootstrap and .htaccess file?
  • Hi i have paste my bootstrap and htaccess on pastebinning as requested. Kindly let me know i was wrong on my settings i have given the absolute path details in my previous discussion.

    http://kohana.pastebin.com/sZXVzcu9
  • Sorry for hijacking this thread, @bluehawk, any new plans for Kohanut? Last commit was on February.

    Thanks for the hard work!
  • @subhashini

    From a glance, everything looks fine.

    @nanodocumet

    I would love to continue developing Kohanut, but have been busy with other projects.
  • I have solved the Issue by changing the base URL to

    "/subha/kohanacms" instead of "subha/kohanacms"

    Thanks for your support.
  • I know this thread is more than 2 years old, but it helped me to install Kohanut - the CMS looks really cool and simple, although I haven't played too much with it yet. It's been a long time since Kohanut has been updated and still appears to run on the older 3.03 version, but shouldn't be too big deal to upgrade to 3.2. I am surprised no-one has picked up what's been left for more than 2 years completely untouched. It would be nice to add some extensions, plugins, themes, etc for this CMS sort of like in Joomla, only with Kohana's beauty underneath it.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion