TIP: Use Markdown or, <pre> for multi line code blocks / <code> for inline code.
These forums are read-only and for archival purposes only!
Please join our new forums at discourse.kohanaframework.org
Introducing Vendo E-Commerce Framework
  • It's been mentioned on random threads here for a while, and I finally think something is "announce-able". Well here it is:

    https://github.com/vendo/vendo

    Vendo is an e-commerce application framework for Kohana 3.0.x. It lets you quickly setup and write e-commerce applications using Kohana. There's still much to do, and any collaboration is happily encouraged! :)

    It uses strict MVC separation including using KOstache views for it's demo application, and is partially tested for it's fairly small codebase.

    It currently only supports the authorize.net payment gateway, but others should be easy to write and I encourage you to submit new gateway drivers to the project. "In-between" gateways like paypal and google checkout are still in the design phase.

    It's split into it's own organization, with individual repositories for each module.

    You can check out the main readme here: https://github.com/vendo/vendo/blob/develop/README.md

    Much of the information there is currently being transferred to the wiki here (still needs to be fully fleshed out):

    https://github.com/vendo/vendo/wiki

    If you were following vendo from zombor/vendo, you'll want to switch to following the Vendo organization. I'll soon be deleting the zombor/vendo repository.

    Small note, I'm looking for someone to fix/port the ORM user model for vendo. I have a broken version checked in at https://github.com/vendo/core/blob/develop/classes/model/vendo/core/user/orm.php
  • I just downloaded vendo and ran the schema script and I got the error below. I don't have much experience with foreign keys and constraints so I'm not sure how to go about fixing it. I'm testing it locally on MAMP 1.9 which has MySQL 5.1.44 and PHP 5.3.2 any help would be great, thanks


    <pre>
    Error
    SQL query:

    CREATE TABLE `contacts` (

    `id` BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
    `email` VARCHAR( 50 ) NOT NULL ,
    `first_name` VARCHAR( 50 ) NOT NULL ,
    `last_name` VARCHAR( 50 ) NOT NULL ,
    `address_id` BIGINT( 20 ) UNSIGNED NOT NULL PRIMARY KEY ( `id` ) ,
    CONSTRAINT `fk_contacts_address_id` FOREIGN KEY ( `address_id` ) REFERENCES `addresses` ( `id` ) ON DELETE CASCADE
    ) ENGINE = INNODB DEFAULT CHARSET = utf8;

    MySQL said:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(`id`),
    CONSTRAINT `fk_contacts_address_id` FOREIGN KEY (`address_id`) REFERE' at line 7
    </pre>
  • @imartingraham
    It seems your mysql server have no InnoDB support
  • awesome! I see you managed to grab the Vendo organization name on github

    I'll dig in sometime soon, when I have a little bit more free time (after this deadline...)
  • Hi.

    Nice work. How do you plan to support product variants? And what about multilingual support?
  • Theres no planned design for product variants yet. i18n isnt really something the framework needs to handle. That would be part of the app you write using kohana with the vendo framework.
  • > you'll want to switch to following the Vendo organization

    Maybe I'm a noob, but I don't see any way to follow an organization (except each repository individually). Am I missing something?
  • hrm, I thought you could...well vendo/vendo should do the same.
  • Thanks p00h, I'll look in to it
    Also @zombor, I think you may have an error in your .gitmodules file. I was getting errors on the vendor-admin modules the path was git@github.com:vendo/admin. When I changed it to git://github.com/vendo/admin it pulled the module without error
  • Thanks, I've fixed it.
  • I've got a bunch of docs out today, so I'm bumping this.

    https://github.com/vendo/vendo/wiki
  • Hi, love this!

    I'll be looking into this module a little deeper later, but I'm hoping to be able to use it for a multiple vendor site. It looks like it can be extended to support this, but I just wanted make sure there isn't anything in its architecture that'd stop me from using it in this way?

    Thanks
  • Nope, the code is written as kohana modules, which are for that exact purpose.
  • I can't checkout 'vendor-admin' module. It says something like "fatal: reference is not a tree:" Unable to checkout '59426e925b82f49d04d1d543a932461a0dd9a2f7' in submodule path 'modules/vendo-admin'
  • Should be fixed now, thanks for letting me know.
  • @zombor: the same error happens with vendo-acl.

  • I just pushed up some new changes now, and tested a fresh clone and it seems to work now.

  • Thanks, it's working now, at least for the git part.

    Do you know about this error?

    ErrorException [ Fatal Error ]: Call to undefined method Model_Vendo_Product_Category::load()

    Might be the 3.5 version of AutoModeler?

    Edit: yes, the new version solves the problem.

  • Yeah, im in the middle of reworking a lot of things in vendo. Develop branch should be in a working state soon.

  • discover the "Vendo" researching tree of categories, I created a small ecommerce with KO3, I take a look at the "Vendo" to see if I answer. My official language is Portuguese of Brazil, the issue of internationalization will be interesting. great project.

  • I've upgraded vendo develop branch to 3.1 last night. Everything seems to work great. If you need to see an example of upgrading from 3.0 to 3.1, take a look :)

  • hello, I downloaded the "Vendo" and I'm trying to start with him but it appear that error.

    erro install vendo

  • Did you follow the install instructions? You can't use the download zip from GitHub.

  • What instructions?

    Well, I used the normal installation process Kohana, then put modules "vendo-* and modified the "bootstrap.php" and "index.php" and others as it was showing error.

    I'll try the individual modules.

    I just stopping this error? 'ErrorException [ 8 ]: Array to string conversion ~ SYSPATH/classes/kohana/core.php [ 1423 '

  • You need to use Kohana 3.1 system folder. It's not compatible with 3.0 anymore.

  • Thanks, This it!

  • Sorry my question, but I'm trying to resolve this error in seeing, know what can be?

    erro vendo

  • You have two problems here:

    1. You are running 3.0 system.
    2. You are running 3.0 index and bootstrap.

    This was mentioned above. Vendo is 3.1+ only now.

  • I think I'm downloading the kohana wrong then, I'll try again.

    get https://github.com/kohana/core/tree/unstable

  • Not like working with do not understand, I'm not even an experienced developer, I'm struggling to understand these errors. I'll wait for an update. "Like a spoiled child"

    I'll try to understand better the application.

    Sorry English is not the official language.

  • You are downloading the wrong repo.

    You should clone the whole base vendo repo:

    git clone --recursive git://github.com/vendo/vendo.git

    This will get you everything you need.

  • You should clone the whole base vendo repo:
        git clone --recursive git://github.com/vendo/vendo.git
    
    This will get you everything you need.

    I've done this, and built a local DB, but I get the following error:

        ErrorException [ Fatal Error ]: Call to undefined method Model_User::can()
    
        MODPATH\vendo-application\classes\view\layout.php [ 113 ]
    
            108      */
            109     public function account_links()
            110     {
            111         $links = array();
            112 
            113         if (Auth::instance()->get_user()->can('manage_preferences'))
            114         {
            115             $links[] = array(
            116                 'location' => 'user/manage',
            117                 'text'     => 'Manage My Account',
            118             );
    
        {PHP internal call} » Kohana_Core::shutdown_handler()
    

    The most likely explanation is that I've done something wrong, but on the off chance it's not me, are files in the repo maybe out of sync?

  • git clone --recursive git://github.com/vendo/vendo.git

    fatal: reference is not a tree: aeccfedce3d783db720e89c2ec1591f517a84a70 Unable to checkout 'aeccfedce3d783db720e89c2ec1591f517a84a70' in submodule path 'modules/vendo-core'

  • Thanks; I hadn't noticed that. Just re-tried the git to double-check, and there it is.

  • fatal: reference is not a tree

    I forgot to push the core changed I did last night. It should work now.

  • I forgot to push the core changed I did last night. It should work now.

    I can now perform the git with no errors reported, but I'm still getting the same message as above, where the can method does not exist.

  • Are you using a stock, fresh checkout of vendo? Auth::get_user() has been overloaded by a custom auth.php file to return a Model_Vendo_User object, not a Model_User object. If you have your own auth.php file in your application directory, this won't work.

  • Are you using a stock, fresh checkout of vendo?

    I am, yes. There's nothing in my local vendo that's not from the git.

  • Do you also have the ORM module? The Model_User from it may be getting in your way.

  • I can't see any reason this would happen from the stock clone. modules/vendo-core/auth.php should be providing the proper functionality.

  • I was going through the code and I found "Shard the file on the filesystem". Could someone explain why this is done? What are the advantages doing this?

    $shards = array(); for ($i = 0; $i<=4; $i+=2) { $shards[] = substr($this->filename, $i, 2); } $path = APPPATH.'photos/'.implode('/', $shards).'/';

  • So you don't end up with a billion files in the same directory.

  • FYI, I have google checkout support working. Docs for it will be coming soon.

  • I can't see any reason this would happen from the stock clone. modules/vendo-core/auth.php should be providing the proper functionality.

    Tried again, and also tried on another system, and same error as before, but just to check: I've been assuming that after performing the git, setting up the DB (and altering my local .htaccess and bootstrap.php), I should need to do nothing else than just browse to my local vendo and watch the magic happen. Is this correct, though, or is there more I need to do?

  • I just tried:

    git clone --recursive git://github.com/vendo/vendo.git
    cp ../../../vendo.old/application/config/* .
    chmod 777 cache logs
    

    And I got this:

    image

  • Now this is interesting. I generally use Firefox, and didn't think to try other browsers until I noticed you using Safari in your screenshot, but it works in:

    Chrome 11.0.672.2 dev IEs 6, 7, 8, and 9RC1 Safari 5.0 Opera 11

    It won't work in Firefox 3.6.13 or Firefox 4b12, even after clearing the cache and restarting. I'll try on the other machine later.

  • The error you were reporting earlier shouldn't have anything to do with your browser:

    image

  • The error you were reporting earlier shouldn't have anything to do with your browser

    Oh, I realise that, and I'm grateful for your attempts to help (as well as being grateful to you for releasing Vendo). I was just interested as to why the cache wouldn't clear, despite clearing the cache through options and through manually deleting the contents of the cache folder of my profile, and restarting, which is normally sufficient in itself for dealing with local caching issues.

    I've no idea what was causing this 'forced cache' (for want of a better term), but I've now finally got ride of it by starting Firefox in safe mode, closing it, then reopening it as normal.

  • Is there a live demo of this available anywhere?

  • Not publicly. It's an e-commerce framework, not a final application.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion